Lexus NX Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Just after 2 days of my purchase, the navigation screen (some might call it infotainment) on my new Lexus NX 200t began to restart randomly.

It'll work for about 10 minutes, then black out, restart, then work for another 5-10 minutes , then restart again . Usually after 30 minutes of driving, the navigation screen would only work for 1-3 minutes and then restarted.

I took the vehicle to the Lexus service and they told me it's a "firmware update issue", and promised me the problem will be fix. I drive it away and unfortunately in the next two day, the screen totally went off completely and would never respond to anything again. Since the infotainment screen is off, other features such as FM/AM/CD/AUX, volume control, USB were dead, too.

I took it to Lexus for the second time. After couple of days, their technician told me it's fixed, and they reset the system. He also mentioned that the reason of these problem might have something to do with me pairing my phone via bluetooth. As per his instruction, I removed my phone from the vehicle's bluetooth list.

After several days of driving, the FM/AM/CD/AUX and volume control are frozen and not responding to anything. However I paired my phone and my wife's phone via bluetooth, and everthing works just fine, as long as you don't have any control of volume since the volumes knobs are freeze at around 18, which is fine.

One week later, which is the day of this post, the infotainment screen began to restarting, again.

As for the Lexus service and dealership, they promised me to fix the problem (for the third time, though), and I have to bring in my NX 200 this weekend.

I'll keep update on this and if anyone is experiencing the same issue you're welcome to follow this post.
 

·
Registered
Joined
·
4 Posts
Hi Everyone,
I've just finished reading all of the posts on problems with the Navigation display.
But I haven't seen my problem listed yet:
I have a 200t with luxury pkge since July 2015 (manufacture date April 2015).
Everything was fine till 2 weeks ago when Nav system would load and I got a screen message saying it was unable to access the SD card and instructing to reload it.
I didn't and instead just shut the engine off and back on an it rebooted and then started working again.
That lasted for 1 day and then same Caution message. Only the Nav features stopped working on the display......
2 days later it started working again until this past week when the Nav display zoomed out to over 100km and wouldn't allow me to zoom in any closer......some of the other features like street names changed as I was driving but the map itself was unusable.
Interestingly, when I checked the Map Version data display, it showed no map version details at all. 2 days later I'm back to the same Caution message as above and no Nav display at all.
I've contacted the dealer and submitted a Nav discrepancy form and am waiting to hear the outcome.
Anyone else ever encountered a similar issue?
 

·
Registered
Joined
·
106 Posts
I would wait and let the dealer fix the issue. Your SD card that contains the map info might have to be reinserted or might have an issue but the manual states removing the SD card may deactivate your NAV system. It's behind the flip door between and below your Volume and Stereo (scroll) dials on the center console.
 

·
Registered
Joined
·
4 Posts
Thanks.....I noted that in the Manual as well......still waiting on the Dealer......fortunately all the other audio, video and blue tooth features are still working.
 

·
Registered
Joined
·
246 Posts
Thanks.....I noted that in the Manual as well......still waiting on the Dealer......fortunately all the other audio, video and blue tooth features are still working.
Don't jinx it! Who knows, next week someone might report a new set of issues :D
 

·
Registered
Joined
·
4 Posts
So the latest update is that after reviewing my Nav Discrepancy form, the dealer had me bring it in for a Firmware update to solve the problem...so they did that...but it failed to fix it.....so after further consideration they have now decided that my "radio head unit" needs to be replaced.....1-2 weeks to get the replacement unit.......hmmm, this sounds familiar from the previous posts on Navigation issues.:(
 

·
Registered
Joined
·
19 Posts
So the latest update is that after reviewing my Nav Discrepancy form, the dealer had me bring it in for a Firmware update to solve the problem...so they did that...but it failed to fix it.....so after further consideration they have now decided that my "radio head unit" needs to be replaced.....1-2 weeks to get the replacement unit.......hmmm, this sounds familiar from the previous posts on Navigation issues.:(
just like going to a doctor... a lot of trial-n-error, just because they don't know WHY , I am pretty sure someone knows the root cause of this problem. With the advanced in technology, we seem to lose the skills in diagnosing problems/issues. I would fire all of my scientists who have the trial-n-error mentality WITHOUT knowing WHY ;)
 
1 - 9 of 9 Posts
Top