Lexus NX Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Our NX 200t has the unresponsive display problem. Going into the shop this week. They don't have a fix for it yet and will keep the car until Lexus finds one.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #4
I must add that Lexus of Akron Canton responded to my email within an hour or so with a plan of action. I am happy with that!
 

·
Registered
Joined
·
14 Posts
So sorry to hear this rsynder. It seems that right now they are replacing the nav/radio units and returning to owner. Hopefully they are making progress on determining root cause.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #6
So sorry to hear this rsynder. It seems that right now they are replacing the nav/radio units and returning to owner. Hopefully they are making progress on determining root cause.
That's OK with me. As long as the problem goes away. I hope I don't have to reinstall the EnForm afterwords.

On a brighter note... They gave us a brand new ES300 Hybrid as a loaner car. Not as nice as the NX, but quite comfortable. Very strange having the motor shut off at every stop though!
 

·
Registered
Joined
·
1,041 Posts
That's OK with me. As long as the problem goes away. I hope I don't have to reinstall the EnForm afterwords.

On a brighter note... They gave us a brand new ES300 Hybrid as a loaner car. Not as nice as the NX, but quite comfortable. Very strange having the motor shut off at every stop though!
Now that's a nice loaner to have, seem them on the street and they look great, lexus has really come a long way with the ES, much more premium now, not so much of a camry rebadge.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #8
We got our NX back from the dealer this morning. No fix at this time. Lexus says it's a problem with the pairing of phones to the system. If we un-pair our phones, the problem will go away. They are working on a "fix", and we will be contacted when it is available.

Sounds to me like every NX made to this point will have this problem.
 

·
Registered
Joined
·
800 Posts
We got our NX back from the dealer this morning. No fix at this time. Lexus says it's a problem with the pairing of phones to the system. If we un-pair our phones, the problem will go away. They are working on a "fix", and we will be contacted when it is available.

Sounds to me like every NX made to this point will have this problem.
I've heard some complaints about this before. It is a sucky problem to have, but it seems like something they should be able to figure out pretty quick, and once that happens it won't be hard to roll that out to the affected vehicles.
 

·
Registered
Joined
·
6 Posts
We got our NX back from the dealer this morning. No fix at this time. Lexus says it's a problem with the pairing of phones to the system. If we un-pair our phones, the problem will go away. They are working on a "fix", and we will be contacted when it is available.

Sounds to me like every NX made to this point will have this problem.
Interesting how pairing phones will cause this problem.

Did anyone else run in to this issue?
 

·
Registered
Joined
·
36 Posts
Discussion Starter #11
Don't get me wrong! We are 100% happy with our NX. This minor glitch is nothing in my opinion! I know it can be fixed with a software or firmware update.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #13
We have not unpaired yet. Just waiting on a fix. My wife's phone is the only one paired. It's a Samsung Galaxy.
 

·
Registered
Joined
·
17 Posts
I have my NX 20t for two months and so far I don't have any problem with the display.
I pair my IPhone 4S and everything works well.
However I have been experiencing some funny stuff with the USB stick I use. Sometimes the system doesn't recognize the USB stick and I have to unplug and plug again. This is always solving the issue.
Hope Lexus will find the issue causing the problem with the unresponsive display.
 

·
Registered
Joined
·
1,041 Posts
I have my NX 20t for two months and so far I don't have any problem with the display.
I pair my IPhone 4S and everything works well.
However I have been experiencing some funny stuff with the USB stick I use. Sometimes the system doesn't recognize the USB stick and I have to unplug and plug again. This is always solving the issue.
Hope Lexus will find the issue causing the problem with the unresponsive display.
Interesting. Maybe a hard reset might help? But i'm not sure how to do that.
Even worse if it's something to do with the USB port, but hopefully it's all software related.
 

·
Registered
Joined
·
36 Posts
Discussion Starter #16
Interesting. Maybe a hard reset might help? But i'm not sure how to do that.
Even worse if it's something to do with the USB port, but hopefully it's all software related.
We have learned to reset the system by holding in the radio volume knob for a few seconds.
 

·
Registered
Joined
·
14 Posts
We have learned to reset the system by holding in the radio volume knob for a few seconds.
How is your nav issue? Has lexus informed you on SW update status?
On other nx forum ,posters with similar problem had the center console replaced. This includes vehicle purchased by consumer reports .
 

·
Registered
Joined
·
3 Posts
My NX developed the freeze up/ non responsive infotainment system on the second day of ownership. The infotainment system will freeze or become non responsive. No software or firmware update is available. The fix is to remove the radio/that controls the infotainment system. Its a matter of removing some trim pieces and slide out the old radio and in with the new. My dealer is located in Merrillville IN. and ordered the new system immediately and was changed out within a week. I am confident this will fix the issue. I know I'm not comparing apples to apples but a friend had a 2013 santa fe sport with similar issues within a week of ownership and the fix was a new radio/infotainment system and has no problem since. It is odd that there is no software fix?
 

·
Registered
Joined
·
14 Posts
My NX developed the freeze up/ non responsive infotainment system on the second day of ownership. The infotainment system will freeze or become non responsive. No software or firmware update is available. The fix is to remove the radio/that controls the infotainment system. Its a matter of removing some trim pieces and slide out the old radio and in with the new. My dealer is located in Merrillville IN. and ordered the new system immediately and was changed out within a week. I am confident this will fix the issue. I know I'm not comparing apples to apples but a friend had a 2013 santa fe sport with similar issues within a week of ownership and the fix was a new radio/infotainment system and has no problem since. It is odd that there is no software fix?
Your dealer response is consistent with what I read regarding others. I can't help but think if this was purely a SW issue, it would have been found and addressed during lexus testing. It seems like there is a percentage of nav components that have some anomaly that doesn't play nice with the SW. Who knows what the eventual fix will be (hw, SW, firmware, combo)
 
1 - 20 of 28 Posts
Top